Feedback by UserVoice

How can we improve compliance or protect your users better in Office 365?

Allow to see private emails in shared mailboxes in outlook (in OWA you can see them)

Short:

On shared mailboxes in office 365 emails that are flagged by the sender as private are hidden. In OWA they are visible.

Long:

Users having full access to the shared mailbox do not see emails sent with a private flag - and they do not get informed about it. The emails are just silently hidden by outlook without any further notice. Quite stupid, for a shared mailbox (e.g. incoming orders!)

We discovered that by coincidence: Our users were concerned because the number of unread emails was increasing - although there were no unread emails visible for them.

If they open the same mailbox in OWA, they can actually SEE the private email!

Improvement:

1. Get consistent behavior between OWA and Outlook.

2. Let an administrator configure right to see the private messages on shared mailboxes.

384 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    28 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Steven Underwood commented  ·   ·  Flag as inappropriate

        Our users see an unread message count, but can not see the message. The fix to convert to a regular mailbox, delegate with private and convert back worked, but we have almost 200 shared mailboxes.

        Please put a request into the developers to include an option to allow administrators to allow private messages to be delivered to shared mailboxes in Outlook. It can even be off by default if there are security questions.

      • Rob Traynere commented  ·   ·  Flag as inappropriate

        You can resolve this with a transport rule, FYI.

        Have it target emails sent to an OU / Security Group containing all shared inboxes, and have it modify the message to remove the private flag.

        Also should have it modify the subject line to show modification to end users and possibly auto-reply to sender letting them know private flag was removed.

      • Chris Cox commented  ·   ·  Flag as inappropriate

        I have a similar issue but regarding private calendar appointments.
        When i migrated from Exchange 2010 to Exchange online, all seemed to go great, but months later a user has noticed a major issue.

        Under 'Resources' -> 'Rooms' i converted our Meeting Room and Boardroom mailboxes into a room (resource).
        If i send an appointment to the room it logs the appointment in the calendar of the room.
        If i send an appointment that is marked as 'Private' it shows in the room calendar as a Private Appointment.
        I know your thinking 'yeah and....'
        What has changed is that when on Exchange 2010, the appointment would show the organisers name so we knew who the appointment was made by but didn't show the subject line or the body of the appointment (couldn't actually click into it either).
        Now in Exchange online, it has automatically set the 'RemovePrivateProperty $false' meaning that it shows as a private appointment but no one can see who made the apppointment. If i set to $true the appointment is visible to all and so is the content.

        So if tried setting the 'deletecomments' and 'deletesubject' and 'addorganisertosubject' and these all work however it's not the right solution.

        What i want is that if someone sends a normal appointment, all the fields are available to view.
        If someone sends a private appointment, they only see who the organiser is and nothing else.

        Has anyone else had this issue and found how to resolve it?

        Many thanks in advance all!

      • Jonathan Khor commented  ·   ·  Flag as inappropriate

        There are legitimate reasons for using private email messages. The feature to allow shared mailbox delegates to view these items was available in on-premise Exchange. Why is it now being crippled in Exchange Online? Disappointing.

      • Ross Curtis commented  ·   ·  Flag as inappropriate

        Seriously Microsoft, why would you remove a feature that has been available for previous versions of Exchange? Makes me want to migrate everything back On-Prem!

      • Walter commented  ·   ·  Flag as inappropriate

        I´m having the same issue with a user, I tested everything but it doesn´t work.

      • Paul commented  ·   ·  Flag as inappropriate

        Hello, we've just 'discovered' this as well. This could have had a potentially serious impact to the organisation as our shared mailboxes are only normally accessed by Outlook and emails were not being picked up.

        It needs to be a grantable permission/tick box in O365 that will apply to shared mailboxes.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Same problem here, there is a workaround by converting the mailbox to a normal mailbox with a license, assigning permissions and converting it back to a shared mailbox, but thats too time consuming.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Ran into this issue this week. Due to the nature of our business we use a lot of shared mailboxes. Workarounds just not acceptable and extremely bad practice. How do we get this changed? make placards and march on MSO365 Ivory Tower?

      • Anonymous commented  ·   ·  Flag as inappropriate

        This needs to happen ASAP, I work in the Healthcare, and have shared mailboxes set up for a couple of departments, because of HIPPA we must send and receive encrypted emails, which some like mimcast automatically mark as private as well, this is a huge pain point and something MS should work on quickly.

      • Andrew commented  ·   ·  Flag as inappropriate

        Just ran into this issue the other day. Users and managers are very upset at potential lead loss due to this issue...

      • Anonymous commented  ·   ·  Flag as inappropriate

        I've just had to explain this quirk to my manager. It's baffling that there isn't the check box option available to admins.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Bump. Agree with all comments below. Users are very upset about missing orders and other critical messages.

      • Richard Aylin commented  ·   ·  Flag as inappropriate

        This is now getting to be a significant issue. Because of new GDPR regulations, senders are being more paranoid about security and sending increased volumes of "private" emails to shared mailboxes. This is causing us massive headaches. Please can we get a solution rather than laborious workarounds??

      • Matt commented  ·   ·  Flag as inappropriate

        We can't have users looking for unread items in Outlook and OWA on the off chance there is an item marked as Private. This is just daft behaviour. We need the option to disable the Private flag in a shared mailbox - the default is unworkable - the workaround of converting to a User mailbox and then giving Delegate Access the ability to see Private items is no good when you have 9000 shared mailboxes. There should be a Powershell cmdlet "Set-Mailbox -IgnorePrivate $true"

      • Tim Stark commented  ·   ·  Flag as inappropriate

        Why isn't this added yet, it is a huge deal to HR departments.

        +1 on the urgency for this!

        I suggest everyone bumps this up.

      ← Previous 1

      Feedback and Knowledge Base