Feedback by UserVoice

I suggest you ...

Outlook is not syncing and giving a "Need password" message

I have several users that over the last 1-2 months increasingly have experienced that their Outlook wont sync. All of them then experience as message in the bottom of the Outlook screen that says "Need password", but if you click it, you just get a quick blink of a white screen, and then it disappears.

While the issue is present for the users, it is not possible for them to create a new Outlook profile, as it wouldn't connect to the mailbox. I had luck with just rebooting my own computer, that fixed the issue for me, but only until the next day. Other users had bigger problems getting it to work.

The issue apparently seems to be an implementation on "Web Account Manager" (WAM) in Office/Windows. The solution is to set below registry key to 1 in below path.

Path: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
Key: DisableADALatopWAMOverride (DWORD)

There is a bit more information on the error on below links. As said, the issue is resolved with above registry fix, but it obviously isn't optimal, and preferably it would be fixed by a software patch, either for Windows or Office.

https://support.microsoft.com/en-us/help/4025962/you-can-t-sign-in-after-you-update-to-office-2016-build-16-0-7967-or-a
https://www.reddit.com/r/Office365/comments/7kklt2/autodiscover_issue_on_outlook_2016_o365_exchange/
https://community.spiceworks.com/topic/2025536-outlook-2016-365-keeps-asking-for-credentials?page=3

354 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Rasmus Dybro shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    65 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Lisa T commented  ·   ·  Flag as inappropriate

        SOLUTION: Settings>Accounts>remove account from "access work or school" worked! Thanks!!

      • Ross commented  ·   ·  Flag as inappropriate

        as Vijay said, removing your account from the "access work or school" part of Windows 10 settings fixes the problem. Not sure if the problem will return, but it is a good work around.

      • Leo commented  ·   ·  Flag as inappropriate

        If you have office365 sync with AD you can use Ctrl+Alt+Del and chose to change your windows login password.
        Then outlook will prompt for new password and you can enter the new password, and everything is fine :)

      • Vijay commented  ·   ·  Flag as inappropriate

        "No Registry changes, just removing the account (if it exists) in this Windows settings area: Settings/Accounts/"Access work or school" area. "
        - This worked for me

      • CC commented  ·   ·  Flag as inappropriate

        What exactly is this change disabling? DisableAADWAM

      • Anonymous commented  ·   ·  Flag as inappropriate

        This worked for me, It would been nice if someone did a step by step instructions for some of us who don't have the experience modifying the registry.

        Thanks

      • Brian commented  ·   ·  Flag as inappropriate

        Here's one that I don't think has been suggested yet. See the response from Joe Backiewicz at the bottom of p.1.
        https://answers.microsoft.com/en-us/msoffice/forum/all/my-outlook-says-need-password-when-i-click-it-it/4d7494f9-a7dd-4ce4-959c-e504f397d230

        No Registry changes, just removing the account (if it exists) in this Windows settings area: Settings/Accounts/"Access work or school" area.

        I don't know what kind of crazy clash is occurring between Outlook and that, especially out of the blue, but it's the only thing that solved it for me, and I tried everything else.

      • DP commented  ·   ·  Flag as inappropriate

        DisableAADWAM worked for me. Mine is Windows 10, 64 bit. I use Outlook 365.
        I followed this process as shared by DustinP....

        A step by step for those (like me) that were a bit rusty:
        Start>Run>regedit
        navigate to the file path on the left side of screen to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
        once at the above location, rigth click in white space on right hand side (or on the top tabs Edit>New), select DWORD (32 bit). Note- My laptop is 64 bit but I still chose 32 bit option and it worked.
        give it the exact name "DisableAADWAM"
        double click (or right click>Modify) on DisableAADWAM and change its value to 1
        restart Outlook

      • Krishna commented  ·   ·  Flag as inappropriate

        DisableADAWAM (DWORD) didnt work but what worked is the original key: Key: DisableADALatopWAMOverride (DWORD)

        Thank you for fix

      • Brian commented  ·   ·  Flag as inappropriate

        Last commenter:

        DisableADAWAM isn't mentioned anywhere else though. Seems hard to believe it could be right for any version of Office.

        Your logic is just because DisableADALatopWAMOverride and DisableAADWAM are different in the middle?! What if those middles stand for different things, like Azure Active Directory Authentication Library (ADAL) and Azure Active Directory (AAD)?

      • Brian Podhajsky commented  ·   ·  Flag as inappropriate

        The above solution is INCORRECT for Office 2019 Build 16.0.11126.20234 32-bit.

        I had the same issue, only affecting one user of many in their org. Never got an error code until after uninstalling McAfee SMB Protection, which I suspected for firewall/network traffic issues. Then I found this article, only to realize that another tech had already been in the registry and created DisableADALatopWAMOverride set to 1. I deleted the key and tried DisableAADWAM set to 1 but this also failed.
        Rereading, I noticed the old key was DisableADALatopWAMOverride while the newer version was listed as DisableAADMWAM
        only after many failed attempts did I realize that there was a typo:
        ADA vs AAD
        deleted the old key, replaced with the following-
        Path:
        HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
        The CORRECT Key for 2019 and possibly other newer versions:
        DisableADAWAM (DWORD) set to Value (1)

        This worked for me without further prompts for the Password. Reinstalled McAfee and the user is good to go.

        It seems like DisableAADWAM may have worked for some people, or maybe they typed it as ADA without realizing it. Very confusing.

        Either way, MS got some 'splainin to do...

        ... just found out about the Mandela Effect on that phrase, so I don't even know what to believe anymore. If the ME applies to registry keys we are done for.

      • David Schrag commented  ·   ·  Flag as inappropriate

        Fixed with HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity | DisableAADWAM = 1 on Office 2016 build 11126.20266 and an Outlook restart. Can't believe there's no fix for this more than a year since first reported.

      ← Previous 1 3 4

      Feedback and Knowledge Base